Frege – 由 package.json 逆向生成 npm install/yarn add 安装命令的工具

更新 v0.2: 支持生成 yarn 安装脚本, 使用 -y 或者 --yarnInstall 参数


frege 是什么?

frege 可以从一个现有的 package.json 逆向生成安装所需的 npm install 脚本. 特点是可以选择仅生成生产环境或者开发环境包安装脚本, 并且能够正确将 version range 转成 npm install 所需的语法.

安装

建议把 frege 安装到全局, 然后就可以在命令下直接使用了.

npm install frege -g

使用

参数说明

frege [options]

基本配置:
-f, --file String 要解析的 package.json 文件, 默认会解析当前目录下名为 package.json 的文件 - default: package.json
-l, --latest 不管 package.json 中 npm 包的具体版本号, 安装该包的最新版本 - default: false
-p, --productionOnly 仅生成 dependencies 项目下 npm 包的安装脚本. - default: false
-d, --devOnly 仅生成 devDependencies 项目下的 npm 包的安装脚本, 即开发使用的. - default: false
-h, --help Show help
-v, --version Output the version number

示例

frege

frege

不带任何参数直接运行 frege 命令将生成当前目录下 package.json 文件中 dependenciesdevDependencis(如果有的话) 全部 npm 包的安装脚本, 例如:

npm i -S debug@">=2.6.8 <3.0.0" optionator@">=0.8.2 <0.9.0" semver@">=5.3.0 <6.0.0" npm i -D ava@">=0.19.1 <0.20.0" chai@">=4.0.1 <5.0.0" eslint@">=3.19.0 <4.0.0" tap-nyan@">=1.1.0 <2.0.0"

frege -p

frege --productionOnly

的缩写, 仅生成 dependencis 下面 npm 包的安装脚本.

npm i -S debug@">=2.6.8 <3.0.0" optionator@">=0.8.2 <0.9.0" semver@">=5.3.0 <6.0.0"

frege -d

frege --devOnly

的缩写, 仅生成 devDependencis 项下面 npm 包的安装脚本.

npm i -D ava@">=0.19.1 <0.20.0" chai@">=4.0.1 <5.0.0" eslint@">=3.19.0 <4.0.0" tap-nyan@">=1.1.0 <2.0.0"

frege -l

frege --latest

的简写, 安装 npm 包的最新版本, 而不是原有 package.json 中指定的版本范围.

npm i -S debug optionator semver
npm i -D ava chai eslint tap-nyan

frege -f ../augustine/package.json

指定要解析的 package.json 文件的完整路径.

有问题欢迎反馈!

github 地址: https://github.com/princetoad/frege
npm 地址: https://www.npmjs.com/package/frege

范圣刚 <tom@tfan.org>

回复